zabbix 3.0邮件报警

安装zabbix 3.0之后,写的脚本一直发信不成功,手动执行时可以的。
那是因为zabbix3.0之后,可以自定义参数了。所以不写参数,它是不会传参数的。
在2.x版本不存在这个问题,默认会传3个参数。

1
2
3
4
# cat alert_mail.log
sendEmail[9271]: ERROR => You must specify at least one recipient via -t, -cc, or -bcc
# cat alert_sms.log
手机机号码不能为空
閱讀全文 »

hive整合hadoop通过flume+hue收集日志

hive作为hadoop集群架构之上的一个架构,通过一种类SQL的解析引擎来将作业转换成map/reduce执行的任务。

本文主要是分享基本的安装与使用经验。hive的实质是将表对应到HDFS中的目录。

准备工作

添加环境变量

1
2
3
4
5
6
7
8
9
10
11
12
13
export JAVA_HOME="/usr/local/jdk1.7.0_09"
export CLASSPATH=.:$CLASSPATH:$JAVA_HOME/lib:$JAVA_HOME/jre/lib
export PATH=$PATH:$JAVA_HOME/bin

export HADOOP_HOME="/home/hadoop/hadoop-2.6.4"
export HADOOP_CONF_DIR=$HADOOP_HOME/etc/hadoop/
export CLASSPATH=.:$CLASSPATH:$HADOOP_HOME/lib
export PATH=$PATH:$HADOOP_HOME/bin:$HADOOP_HOME/sbin
export HADOOP_USER_CLASSPATH_FIRST=true

export HIVE_HOME="/home/hadoop/apache-hive-2.1.0-bin"
export CLASSPATH=$CLASSPATH:$HIVE_HOME/lib
export PATH=$PATH:$HIVE_HOME/bin:$HIVE_HOME/conf

设置公钥本机免登陆密码

1
2
ssh-keygen
cp /root/.ssh/id_rsa.pub /root/.ssh/authorized_keys
閱讀全文 »

MySQL查询表内重复记录

MySQL查询表内重复记录

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
-- 1.查找表中多余的重复记录,重复记录是根据单个字段(peopleId)来判断
select * from people
where peopleId in (select peopleId from people group by peopleId having count(peopleId) > 1)

-- 2.删除表中多余的重复记录,重复记录是根据单个字段(peopleId)来判断,只留有一个记录
delete from people
where peopleId in (select peopleId from people group by peopleId having count(peopleId) > 1)
and min(id) not in (select id from people group by peopleId having count(peopleId )>1)

-- 3.查找表中多余的重复记录(多个字段)
select * from vitae a
where (a.peopleId,a.seq) in (select peopleId,seq from vitae group by peopleId,seq having count(*) > 1)

-- 4.删除表中多余的重复记录(多个字段),只留有rowid最小的记录
delete from vitae a
where (a.peopleId,a.seq) in (select peopleId,seq from vitae group by peopleId,seq having count(*) > 1)
and rowid not in (select min(rowid) from vitae group by peopleId,seq having count(*)>1)

-- 5.查找表中多余的重复记录(多个字段),不包含rowid最小的记录
select * from vitae a
where (a.peopleId,a.seq) in (select peopleId,seq from vitae group by peopleId,seq having count(*) > 1)
and rowid not in (select min(rowid) from vitae group by peopleId,seq having count(*)>1)

閱讀全文 »

Startssl免费SSL证书+Nginx搭建https

看到好多小伙伴们都使用了HTTPS
所以为了更好的提高国内用户的访问体验(装13。。)在下也试试看

必备条件

你要有个域名!!!
你要有台server!
你要有备案号!!!
你要有备案号!!!
你要有备案号!!!

以上ok!那么下面我们就开搞!!

閱讀全文 »

flume+hdfs构建大数据

hadoop

http://hadoop.apache.org/docs/r1.0.4/cn/

1
2
3
4
5
6
7
8
9
hdfs dfs -mkdir /ebuyposp
hdfs dfs -mkdir /ebuyposp2
hdfs dfs -ls /

hdfs dfs -cat /ebuyposp1/k1_.1462357028642
hdfs dfs -rm -r -f -skipTrash /ebuyposp/*
hdfs dfs -rm -r -f -skipTrash /ebuyposp2/*
hdfs dfs -rm -r -f -skipTrash /ebuyposp2
hdfs dfs -rm -r -f -skipTrash /test20160428
閱讀全文 »

数据库维护文本编辑技巧记录

作为一个非专业数据库维护人员,日常需要处理格式化大量文本来导入数据库,所以本文用以记录平时遇到的每一个记录!

行首行尾加字符或者符号

  • 工具notepad++
1
2
3
4
ctrl+F 选择替换,并勾选正则表达式

行首 查找目标"^" 替换为"目的字符串"
行尾 查找目标"$" 替换为"目的字符串"
閱讀全文 »

MySQL查询按IN的顺序输出结果

在用 SELECT 查询的时候,如果用到了 IN ,那么查询结果中的顺序并不是按照 IN 后面所给的顺序返回,而是按照默认的升序排列。

而如果想要让查询结果按照 IN 里面给的顺序的话,有最简单方法:

1
2
3
4
5
6
7
8
9
10
11
SELECT 
*
FROM
a
ORDER BY FIELD(
id,
'16556004',
'16552005',
'16558009',
'16551033'
)

CISCO ASA5520 HA 配置

主防火墙配置

接口配置

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address 192.168.2.226 255.255.255.0 standby 192.168.2.241
!
interface GigabitEthernet0/1
nameif inside
security-level 100
ip address 192.168.100.1 255.255.255.0 standby 192.168.100.4
!
interface GigabitEthernet0/2
description STATE Failover Interface
!
interface GigabitEthernet0/3
description LAN Failover Interface

HA配置

1
2
3
4
5
6
7
8
9
failover lan unit primary

failover lan interface HA GigabitEthernet0/3
failover interface ip HA 10.10.10.1 255.255.255.0 standby 10.10.10.2

failover link stateful GigabitEthernet0/2
failover interface ip stateful 10.10.11.1 255.255.255.252 standby 10.10.11.2

failover
閱讀全文 »

centos7配置bond和bond跨网段改IP

一. centos 7下查看网卡信息

命令 ip addr

最小化安装的Centos7系统并没有nano vim wget curl ifconfig lsof命令,这里首先安装一下

yum -y install nano vim wget curl net-tools lsof

安装后就可以使用ifconfig 等命令

配置bond

服务器有4个网卡分别为 ifcfg-em1 ifcfg-em2 ifcfg-em3 ifcfg-em4 网卡ifcfg-em1和ifcfg-em2配置bond0

閱讀全文 »

CentOS下Nginx配置Perl运行Bugzilla

安装LNMP

此处省略。。。

安装perl-fcgi模块

1
2
3
4
5
6
7
8
9
10
yum -y install perl-FCGI

#或者源码编译安装

wget http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/FCGI-0.74.tar.gz
tar zxvf FCGI-0.74.tar.gz
cd FCGI-0.74
perl Makefile.PL
make
make install
閱讀全文 »
Fork me on GitHub